What’s Vulnerable › Vulnerabilities
CVE-2022-3395: WP All Export Pro < 1.7.9 - Authenticated SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-25 · updated 2026-06-17
- Weakness: CWE-89
Description
The WP All Export Pro WordPress plugin before 1.7.9 uses the contents of the cc_sql POST parameter directly as a database query, allowing users which has been given permission to run exports to execute arbitrary SQL statements, leading to a SQL Injection vulnerability. By default only users with the Administrator role can perform exports, but this can be delegated to lower privileged users as well.
Affected products
- WP All Export Pro: before 1.7.9 — fixed in 1.7.9
How to fix
Upgrade to a fixed version: WP All Export Pro 1.7.9. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/10742154-368a-40be-a67d-80ea848493a0
- https://wpscan.com/vulnerability/10742154-368a-40be-a67d-80ea848493a0
Get alerted when CVE-2022-3395 or the next vulnerability affects your stack