What’s Vulnerable › Vulnerabilities
CVE-2022-33960: WordPress Social Share Buttons by Supsystic plugin <= 2.2.3 - Multiple Authenticated SQL Injection (SQLi) vulnerabilities
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-22 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple Authenticated (subscriber or higher user role) SQL Injection (SQLi) vulnerabilities in Social Share Buttons by Supsystic plugin <= 2.2.3 at WordPress.
Affected products
- Supsystic Social Share Buttons by Supsystic (WordPress plugin): before 2.2.4 — fixed in 2.2.4
How to fix
Upgrade to a fixed version: Supsystic Social Share Buttons by Supsystic (WordPress plugin) 2.2.4. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/social-share-buttons-by-supsystic/wordpress-social-share-buttons-by-supsystic-plugin-2-2-3-multiple-authenticated-sql-injection-sqli-vulnerabilities
- https://wordpress.org/plugins/social-share-buttons-by-supsystic/#developers
- https://patchstack.com/database/vulnerability/social-share-buttons-by-supsystic/wordpress-social-share-buttons-by-supsystic-plugin-2-2-3-multiple-authenticated-sql-injection-sqli-vulnerabilities
- https://wordpress.org/plugins/social-share-buttons-by-supsystic/#developers
Get alerted when CVE-2022-33960 or the next vulnerability affects your stack