What’s Vulnerable › Vulnerabilities
CVE-2022-33965: WordPress WP Visitor Statistics plugin <= 5.7 - Multiple Unauthenticated SQL Injection (SQLi) vulnerabilities
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-07-25 · updated 2026-06-17
- Weakness: CWE-89
Description
Multiple Unauthenticated SQL Injection (SQLi) vulnerabilities in Osamaesh WP Visitor Statistics plugin <= 5.7 at WordPress.
Affected products
- WP Visitor Statistics (Real Time Traffic): before 5.8 — fixed in 5.8
How to fix
Upgrade to a fixed version: WP Visitor Statistics (Real Time Traffic) 5.8. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wp-stats-manager/wordpress-wp-visitor-statistics-plugin-5-7-multiple-unauthenticated-sql-injection-sqli-vulnerabilities
- https://wordpress.org/plugins/wp-stats-manager/#developers
- https://patchstack.com/database/vulnerability/wp-stats-manager/wordpress-wp-visitor-statistics-plugin-5-7-multiple-unauthenticated-sql-injection-sqli-vulnerabilities
- https://wordpress.org/plugins/wp-stats-manager/#developers
Get alerted when CVE-2022-33965 or the next vulnerability affects your stack