What’s Vulnerable › Vulnerabilities
CVE-2022-33980: Apache Commons Configuration insecure interpolation defaults
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 44.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-06 · updated 2026-06-17
Description
Apache Commons Configuration performs variable interpolation, allowing properties to be dynamically evaluated and expanded. The standard format for interpolation is "${prefix:name}", where "prefix" is used to locate an instance of org.apache.commons.configuration2.interpol.Lookup that performs the interpolation. Starting with version 2.4 and continuing through 2.7, the set of default Lookup instances included interpolators that could result in arbitrary code execution or contact with remote servers. These lookups are: - "script" - execute expressions using the JVM script execution engine (javax.script) - "dns" - resolve dns records - "url" - load values from urls, including from remote servers Applications using the interpolation defaults in the affected versions may be vulnerable to remote code execution or unintentional contact with remote servers if untrusted configuration values are used. Users are recommended to upgrade to Apache Commons Configuration 2.8.0, which disables the problematic interpolators by default.
Affected products
- Apache Software Foundation Apache Commons Configuration: from 2.4 before 2.8 — fixed in 2.8
- Debian Linux: 11.0
- NetApp SnapCenter: all versions
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Commons Configuration 2.8. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/07/06/5
- http://www.openwall.com/lists/oss-security/2022/11/15/4
- https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s
- https://security.netapp.com/advisory/ntap-20221028-0015/
- https://www.debian.org/security/2022/dsa-5290
- http://www.openwall.com/lists/oss-security/2022/07/06/5
- http://www.openwall.com/lists/oss-security/2022/11/15/4
- https://lists.apache.org/thread/tdf5n7j80lfxdhs2764vn0xmpfodm87s
- https://security.netapp.com/advisory/ntap-20221028-0015/
- https://www.debian.org/security/2022/dsa-5290
Get alerted when CVE-2022-33980 or the next vulnerability affects your stack