What’s Vulnerable › Vulnerabilities
CVE-2022-33981
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-06-18 · updated 2026-06-17
- Weakness: CWE-416
Description
drivers/block/floppy.c in the Linux kernel before 5.17.6 is vulnerable to a denial of service, because of a concurrency use-after-free flaw after deallocating raw_cmd in the raw_cmd_ioctl function.
Affected products
- Debian Linux: 9.0, 10.0
- Linux kernel: before 5.17.6 — fixed in 5.17.6
How to fix
Upgrade to a fixed version: Linux kernel 5.17.6. Check the vendor advisory for mitigations.
References
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.17.6
- https://exchange.xforce.ibmcloud.com/vulnerabilities/225362
- https://github.com/torvalds/linux/commit/233087ca063686964a53c829d547c7571e3f67bf
- https://lists.debian.org/debian-lts-announce/2022/07/msg00000.html
- https://seclists.org/oss-sec/2022/q2/66
- https://www.debian.org/security/2022/dsa-5173
- https://cdn.kernel.org/pub/linux/kernel/v5.x/ChangeLog-5.17.6
- https://exchange.xforce.ibmcloud.com/vulnerabilities/225362
- https://github.com/torvalds/linux/commit/233087ca063686964a53c829d547c7571e3f67bf
- https://lists.debian.org/debian-lts-announce/2022/07/msg00000.html
- https://seclists.org/oss-sec/2022/q2/66
- https://www.debian.org/security/2022/dsa-5173
Get alerted when CVE-2022-33981 or the next vulnerability affects your stack