What’s Vulnerable › Vulnerabilities
CVE-2022-3401
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-28 · updated 2026-06-17
Description
The Bricks theme for WordPress is vulnerable to remote code execution due to the theme allowing site editors to include executable code blocks in website content in versions 1.2 to 1.5.3. This, combined with the missing authorization vulnerability (CVE-2022-3400), makes it possible for authenticated attackers with minimal permissions, such as a subscriber, can edit any page, post, or template on the vulnerable WordPress website and inject a code execution block that can be used to achieve remote code execution.
Affected products
- Bricks Builder Bricks: from 1.2 before 1.5.4 — fixed in 1.5.4
How to fix
Upgrade to a fixed version: Bricks Builder Bricks 1.5.4. Check the vendor advisory for mitigations.
References
- https://bricksbuilder.io/
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3401
- https://bricksbuilder.io/
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3401
Get alerted when CVE-2022-3401 or the next vulnerability affects your stack