What’s Vulnerable › Vulnerabilities
CVE-2022-3402: Log HTTP Requests <= 1.3.1 - Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-28 · updated 2026-06-17
- Weakness: CWE-79
Description
The Log HTTP Requests plugin for WordPress is vulnerable to Stored Cross-Site Scripting via logged HTTP requests in versions up to, and including, 1.3.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers who can trick a site's administrator into performing an action like clicking on a link, or an authenticated user with access to a page that sends a request using user-supplied data via the server, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- mgibbs189 Log HTTP Requests: before 1.3.2 — fixed in 1.3.2
How to fix
Upgrade to a fixed version: mgibbs189 Log HTTP Requests 1.3.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2770821%40log-http-requests&new=2770821%40log-http-requests&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/log-http-requests/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b12b0a2a-3c3c-4d9c-a404-c8f170638e31?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3402
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=2770821%40log-http-requests&new=2770821%40log-http-requests&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/log-http-requests/#developers
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-3402
Get alerted when CVE-2022-3402 or the next vulnerability affects your stack