What’s Vulnerable › Vulnerabilities

CVE-2022-3411

Description

A lack of length validation in GitLab CE/EE affecting all versions from 12.4 before 15.6.7, 15.7 before 15.7.6, and 15.8 before 15.8.1 allows an authenticated attacker to create a large Issue description via GraphQL which, when repeatedly requested, saturates CPU usage.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.6.7, 15.7.6, 15.8.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3411 or the next vulnerability affects your stack