What’s Vulnerable › Vulnerabilities
CVE-2022-3415: Chat Bubble < 2.3 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The Chat Bubble WordPress plugin before 2.3 does not sanitise and escape some contact parameters, which could allow unauthenticated attackers to set Stored Cross-Site Scripting payloads in them, which will trigger when an admin view the related contact message
Affected products
- Chat Bubble – Floating Chat with Contact Chat Icons, Messages, Telegram, Email, SMS, Call me back: before 2.3 — fixed in 2.3
How to fix
Upgrade to a fixed version: Chat Bubble – Floating Chat with Contact Chat Icons, Messages, Telegram, Email, SMS, Call me back 2.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/012c5b64-ef76-4539-afd8-40f6c329ae88
- https://wpscan.com/vulnerability/012c5b64-ef76-4539-afd8-40f6c329ae88
Get alerted when CVE-2022-3415 or the next vulnerability affects your stack