What’s Vulnerable › Vulnerabilities
CVE-2022-34157
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-16 · updated 2026-06-17
Description
Improper access control in the Intel(R) FPGA SDK for OpenCL(TM) with Intel(R) Quartus(R) Prime Pro Edition software before version 22.1 may allow authenticated user to potentially enable escalation of privilege via local access.
Affected products
- Intel Fpga Software Development Kit: before 22.1 — fixed in 22.1
- Intel(R) Quartus Prime Pro and Standard edition software: before 21.1; before 21.3 — fixed in 21.1, 21.3
How to fix
Upgrade to a fixed version: Intel Fpga Software Development Kit 22.1; Intel(R) Quartus Prime Pro and Standard edition software 21.1, 21.3. Check the vendor advisory for mitigations.
References
- http://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00728.html
- http://www.intel.com/content/www/us/en/security-center/advisory/intel-sa-00728.html
Get alerted when CVE-2022-34157 or the next vulnerability affects your stack