What’s Vulnerable › Vulnerabilities
CVE-2022-34165
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-09 · updated 2026-06-17
- Weakness: CWE-74
Description
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 and IBM WebSphere Application Server Liberty 17.0.0.3 through 22.0.0.9 are vulnerable to HTTP header injection, caused by improper validation. This could allow an attacker to conduct various attacks against the vulnerable system, including cache poisoning and cross-site scripting. IBM X-Force ID: 229429.
Affected products
- IBM WebSphere Application Server: from 7.0.0.0 through 7.0.0.45; from 8.0.0.0 through 8.0.0.15; from 8.5.0.0 through 8.5.5.22; from 9.0.0.0 through 9.0.5.13; from 17.0.0.3 before 22.0.0.9 — fixed in 22.0.0.9
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 22.0.0.9. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/229429
- https://www.ibm.com/support/pages/node/6618747
- https://exchange.xforce.ibmcloud.com/vulnerabilities/229429
- https://www.ibm.com/support/pages/node/6618747
Get alerted when CVE-2022-34165 or the next vulnerability affects your stack