What’s Vulnerable › Vulnerabilities
CVE-2022-3417: WPtouch < 4.3.45 - Admin+ PHP Object Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-09 · updated 2026-06-17
Description
The WPtouch WordPress plugin before 4.3.45 unserialises the content of an imported settings file, which could lead to PHP object injections issues when an user import (intentionally or not) a malicious settings file and a suitable gadget chain is present on the blog.
Affected products
- WPtouch: before 4.3.45 — fixed in 4.3.45
How to fix
Upgrade to a fixed version: WPtouch 4.3.45. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/55772932-eebd-475b-b5df-e80fab288ee5
- https://wpscan.com/vulnerability/55772932-eebd-475b-b5df-e80fab288ee5
Get alerted when CVE-2022-3417 or the next vulnerability affects your stack