What’s Vulnerable › Vulnerabilities
CVE-2022-3419: Automatic User Roles Switcher < 1.1.2 - Subscriber+ Privilege Escalation
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-269
Description
The Automatic User Roles Switcher WordPress plugin before 1.1.2 does not have authorisation and proper CSRF checks, allowing any authenticated users like subscriber to add any role to themselves, such as administrator
Affected products
- Automatic User Roles Switcher: before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: Automatic User Roles Switcher 1.1.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5909a423-9841-449c-a569-f687c609817b
- https://wpscan.com/vulnerability/5909a423-9841-449c-a569-f687c609817b
Get alerted when CVE-2022-3419 or the next vulnerability affects your stack