What’s Vulnerable › Vulnerabilities
CVE-2022-34256: Adobe Commerce Improper Authorization Privilege escalation
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-16 · updated 2026-06-17
- Weakness: CWE-285
Description
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to access other user's data. Exploitation of this issue does not require user interaction.
Affected products
- Adobe Commerce: from 2.3.0 before 2.3.7; from 2.4.0 before 2.4.3; 2.3.7, 2.3.7-p1, 2.3.7-p2, 2.3.7-p3, 2.4.3, 2.4.3-p1 (+2) — fixed in 2.3.7, 2.4.3
- Adobe Magento Commerce: from 2.3.0 before 2.3.7; from 2.4.0 before 2.4.3; 2.3.7, 2.3.7-p1, 2.3.7-p2, 2.3.7-p3, 2.4.3, 2.4.3-p1 (+2) — fixed in 2.3.7, 2.4.3
How to fix
Upgrade to a fixed version: Adobe Commerce 2.3.7, 2.4.3; Adobe Magento Commerce 2.3.7, 2.4.3. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/magento/apsb22-38.html
- https://helpx.adobe.com/security/products/magento/apsb22-38.html
Get alerted when CVE-2022-34256 or the next vulnerability affects your stack