What’s Vulnerable › Vulnerabilities

CVE-2022-34258: Adobe Commerce Stored XSS Arbitrary code execution

Description

Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an attacker with admin privileges to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.

Affected products

How to fix

Upgrade to a fixed version: Adobe Commerce 2.3.7, 2.4.3; Adobe Magento Commerce 2.3.7, 2.4.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-34258 or the next vulnerability affects your stack