What’s Vulnerable › Vulnerabilities
CVE-2022-34267
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 42.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-12-25 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in RWS WorldServer before 11.7.3. Adding a token parameter with the value of 02 bypasses all authentication requirements. Arbitrary Java code can be uploaded and executed via a .jar archive to the ws-api/v2/customizations/api endpoint.
Affected products
- Rws Worldserver: before 11.7.3 — fixed in 11.7.3
How to fix
Upgrade to a fixed version: Rws Worldserver 11.7.3. Check the vendor advisory for mitigations.
References
- https://www.rws.com/localization/products/trados-enterprise/worldserver/
- https://www.triskelelabs.com/vulnerabilities-in-rws-worldserver
- https://www.rws.com/localization/products/trados-enterprise/worldserver/
- https://www.triskelelabs.com/vulnerabilities-in-rws-worldserver
Get alerted when CVE-2022-34267 or the next vulnerability affects your stack