What’s Vulnerable › Vulnerabilities
CVE-2022-34269
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-02-29 · updated 2026-06-17
- Weakness: CWE-918
Description
An issue was discovered in RWS WorldServer before 11.7.3. An authenticated, remote attacker can perform a ws-legacy/load_dtd?system_id= blind SSRF attack to deploy JSP code to the Apache Axis service running on the localhost interface, leading to command execution.
Affected products
- Rws Worldserver: before 11.7.3 — fixed in 11.7.3
How to fix
Upgrade to a fixed version: Rws Worldserver 11.7.3. Check the vendor advisory for mitigations.
References
- https://www.rws.com/localization/products/trados-enterprise/worldserver/
- https://www.triskelelabs.com/vulnerabilities-in-rws-worldserver
- https://www.rws.com/localization/products/trados-enterprise/worldserver/
- https://www.triskelelabs.com/vulnerabilities-in-rws-worldserver
Get alerted when CVE-2022-34269 or the next vulnerability affects your stack