What’s Vulnerable › Vulnerabilities
CVE-2022-34293
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-08 · updated 2026-06-17
Description
wolfSSL before 5.4.0 allows remote attackers to cause a denial of service via DTLS because a check for return-routability can be skipped.
Affected products
- wolfSSL: before 5.4.0 — fixed in 5.4.0
How to fix
Upgrade to a fixed version: wolfSSL 5.4.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/08/08/6
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.4.0-stable
- http://www.openwall.com/lists/oss-security/2022/08/08/6
- https://github.com/wolfSSL/wolfssl/releases/tag/v5.4.0-stable
Get alerted when CVE-2022-34293 or the next vulnerability affects your stack