What’s Vulnerable › Vulnerabilities
CVE-2022-3437
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-12 · updated 2026-06-17
- Weakness: CWE-122
Description
A heap-based buffer overflow vulnerability was found in Samba within the GSSAPI unwrap_des() and unwrap_des3() routines of Heimdal. The DES and Triple-DES decryption routines in the Heimdal GSSAPI library allow a length-limited write buffer overflow on malloc() allocated memory when presented with a maliciously small packet. This flaw allows a remote user to send specially crafted malicious data to the application, possibly resulting in a denial of service (DoS) attack.
Affected products
- Fedoraproject Fedora: 36, 37
- Samba: from 4.0.0 before 4.15.11; from 4.16.0 before 4.16.6; from 4.17.0 before 4.17.2 — fixed in 4.15.11, 4.16.6, 4.17.2
How to fix
Upgrade to a fixed version: Samba 4.15.11, 4.16.6, 4.17.2. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/02/08/1
- https://access.redhat.com/security/cve/CVE-2022-3437
- https://bugzilla.redhat.com/show_bug.cgi?id=2137774
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
- https://security.gentoo.org/glsa/202309-06
- https://security.gentoo.org/glsa/202310-06
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://www.samba.org/samba/security/CVE-2022-3437.html
- http://www.openwall.com/lists/oss-security/2023/02/08/1
- https://access.redhat.com/security/cve/CVE-2022-3437
- https://bugzilla.redhat.com/show_bug.cgi?id=2137774
- https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html
Get alerted when CVE-2022-3437 or the next vulnerability affects your stack