What’s Vulnerable › Vulnerabilities
CVE-2022-34384
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-02-11 · updated 2026-06-17
- Weakness: CWE-250
Description
Dell SupportAssist Client Consumer (version 3.11.1 and prior), SupportAssist Client Commercial (version 3.2 and prior), Dell Command | Update, Dell Update, and Alienware Update versions before 4.5 contain a Local Privilege Escalation Vulnerability in the Advanced Driver Restore component. A local malicious user may potentially exploit this vulnerability, leading to privilege escalation.
Affected products
- Dell Alienware Update: before 4.5.0 — fixed in 4.5.0
- Dell Command Update (DCU): before 4.5.0 — fixed in 4.5.0
- Dell SupportAssist for Business PCs: through 3.2.0
- Dell SupportAssist Client Consumer: through 3.11.2
- Dell Update: before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: Dell Alienware Update 4.5.0; Dell Command Update (DCU) 4.5.0; Dell Update 4.5.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-34384 or the next vulnerability affects your stack