What’s Vulnerable › Vulnerabilities
CVE-2022-3440: Rock Convert < 2.6.0 - Reflected Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The Rock Convert WordPress plugin before 2.11.0 does not sanitise and escape an URL before outputting it back in an attribute when a specific widget is present on a page, leading to a Reflected Cross-Site Scripting
Affected products
- Rock Convert: before 2.11.0 — fixed in 2.11.0
How to fix
Upgrade to a fixed version: Rock Convert 2.11.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e39fcf30-1e69-4399-854c-4c5b6ccc22a2
- https://wpscan.com/vulnerability/e39fcf30-1e69-4399-854c-4c5b6ccc22a2
Get alerted when CVE-2022-3440 or the next vulnerability affects your stack