What’s Vulnerable › Vulnerabilities
CVE-2022-34427
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-11 · updated 2026-06-17
- Weakness: CWE-78
Description
Dell Container Storage Modules 1.2 contains an OS Command Injection in goiscsi and gobrick libraries. A remote unauthenticated attacker could exploit this vulnerability leading to modification of intended OS command execution.
Affected products
- Dell Container Storage Modules: from 1.3.0 before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Dell Container Storage Modules 2.0.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-vc/000203352/dsa-2022-259-dell-container-storage-modules-security-update-for-multiple-vulnerabilities
- https://www.dell.com/support/kbdoc/en-vc/000203352/dsa-2022-259-dell-container-storage-modules-security-update-for-multiple-vulnerabilities
Get alerted when CVE-2022-34427 or the next vulnerability affects your stack