What’s Vulnerable › Vulnerabilities
CVE-2022-34464
- Severity: low (CVSS 2.1 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-07-12 · updated 2026-06-17
- Weakness: CWE-552
Description
A vulnerability has been identified in SICAM GridEdge (Classic) (All versions < V2.7.3). The affected application uses an improperly protected file to import SSH keys. This could allow attackers with access to the filesystem of the host on which SICAM GridEdge runs to inject a custom SSH key to that file.
Affected products
- Siemens Sicam Gridedge Essential Arm: all versions
- Siemens Sicam Gridedge Essential Gds Arm: all versions
- Siemens Sicam Gridedge Essential Gds Intel: before 2.7.3 — fixed in 2.7.3
- Siemens Sicam Gridedge Essential Intel: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: Siemens Sicam Gridedge Essential Gds Intel 2.7.3; Siemens Sicam Gridedge Essential Intel 2.7.3. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/html/ssa-225578.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-225578.pdf
- https://cert-portal.siemens.com/productcert/pdf/ssa-225578.pdf
Get alerted when CVE-2022-34464 or the next vulnerability affects your stack