What’s Vulnerable › Vulnerabilities
CVE-2022-34470
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-416
Description
Session history navigations may have led to a use-after-free and potentially exploitable crash. This vulnerability affects Firefox < 102, Firefox ESR < 91.11, Thunderbird < 102, and Thunderbird < 91.11.
Affected products
- Mozilla Firefox: before 102.0 — fixed in 102.0
- Mozilla Firefox ESR: before 91.11 — fixed in 91.11
- Mozilla Thunderbird: before 91.11 — fixed in 91.11
How to fix
Upgrade to a fixed version: Mozilla Firefox 102.0; Mozilla Firefox ESR 91.11; Mozilla Thunderbird 91.11. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1765951
- https://www.mozilla.org/security/advisories/mfsa2022-24/
- https://www.mozilla.org/security/advisories/mfsa2022-25/
- https://www.mozilla.org/security/advisories/mfsa2022-26/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1765951
- https://www.mozilla.org/security/advisories/mfsa2022-24/
- https://www.mozilla.org/security/advisories/mfsa2022-25/
- https://www.mozilla.org/security/advisories/mfsa2022-26/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1765951
Get alerted when CVE-2022-34470 or the next vulnerability affects your stack