What’s Vulnerable › Vulnerabilities
CVE-2022-34471
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-22 · updated 2026-06-17
- Weakness: CWE-345
Description
When downloading an update for an addon, the downloaded addon update's version was not verified to match the version selected from the manifest. If the manifest had been tampered with on the server, an attacker could trick the browser into downgrading the addon to a prior version. This vulnerability affects Firefox < 102.
Affected products
- Mozilla Firefox: before 102.0 — fixed in 102.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 102.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1766047
- https://www.mozilla.org/security/advisories/mfsa2022-24/
- https://bugzilla.mozilla.org/show_bug.cgi?id=1766047
- https://www.mozilla.org/security/advisories/mfsa2022-24/
Get alerted when CVE-2022-34471 or the next vulnerability affects your stack