What’s Vulnerable › Vulnerabilities
CVE-2022-3451: Product Stock Manager < 1.0.5 - Subscriber+ Unauthorised AJAX Calls
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The Product Stock Manager WordPress plugin before 1.0.5 does not have authorisation and proper CSRF checks in multiple AJAX actions, allowing users with a role as low as subscriber to call them. One action in particular could allow to update arbitrary options
Affected products
- Product Stock Manager: before 1.0.5 — fixed in 1.0.5
How to fix
Upgrade to a fixed version: Product Stock Manager 1.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/d8005cd0-8232-4d43-a4e4-14728eaf1300
- https://wpscan.com/vulnerability/d8005cd0-8232-4d43-a4e4-14728eaf1300
Get alerted when CVE-2022-3451 or the next vulnerability affects your stack