What’s Vulnerable › Vulnerabilities
CVE-2022-3460
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-03 · updated 2026-06-17
- Weakness: CWE-212
Description
In affected versions of Octopus Deploy it is possible for certain types of sensitive variables to inadvertently become unmasked when viewed in variable preview.
Affected products
- Octopus Deploy Octopus Server: from 2018.1.0 before 2022.3.10750; from 2022.4 before 2022.4.8063 — fixed in 2022.3.10750, 2022.4.8063
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2022.3.10750, 2022.4.8063. Check the vendor advisory for mitigations.
References
- https://advisories.octopus.com/post/2022/sa2022-25/
- https://advisories.octopus.com/post/2022/sa2022-25/
Get alerted when CVE-2022-3460 or the next vulnerability affects your stack