What’s Vulnerable › Vulnerabilities
CVE-2022-34668
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 11.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-29 · updated 2026-06-17
- Weakness: CWE-502
Description
NVFLARE, versions prior to 2.1.4, contains a vulnerability that deserialization of Untrusted Data due to Pickle usage may allow an unprivileged network attacker to cause Remote Code Execution, Denial Of Service, and Impact to both Confidentiality and Integrity.
Affected products
- NVIDIA Nvflare: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: NVIDIA Nvflare 2.1.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/171483/NVFLARE-Unsafe-Deserialization.html
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-6qv6-q77g-7qm6
- http://packetstormsecurity.com/files/171483/NVFLARE-Unsafe-Deserialization.html
- https://github.com/NVIDIA/NVFlare/security/advisories/GHSA-6qv6-q77g-7qm6
Get alerted when CVE-2022-34668 or the next vulnerability affects your stack