What’s Vulnerable › Vulnerabilities
CVE-2022-34680
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-30 · updated 2026-06-17
- Weakness: CWE-197
Description
NVIDIA GPU Display Driver for Linux contains a vulnerability in the kernel mode layer handler, where an integer truncation can lead to an out-of-bounds read, which may lead to denial of service.
Affected products
- Debian Linux: 10.0 (and their updates)
- NVIDIA Cloud Gaming: before 525.60.12; before 525.60.11 — fixed in 525.60.12, 525.60.11
- NVIDIA Guest driver: from 390 before 390.157; from 470 before 470.161.03; from 510 before 510.108.03; from 515 before 515.86.01; from 525 before 525.60.11; from 450 before 450.216.04 — fixed in 390.157, 470.161.03, 510.108.03, 515.86.01, 525.60.11, 450.216.04
- NVIDIA Virtual GPU Software: before 11.11; from 12.0 before 13.6; from 14.0 before 14.4 — fixed in 11.11, 13.6, 14.4
How to fix
Upgrade to a fixed version: NVIDIA Cloud Gaming 525.60.12, 525.60.11; NVIDIA Guest driver 390.157, 470.161.03, 510.108.03, 515.86.01; NVIDIA Virtual GPU Software 11.11, 13.6, 14.4. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2023/05/msg00010.html
- https://nvidia.custhelp.com/app/answers/detail/a_id/5415
- https://security.gentoo.org/glsa/202310-02
- https://lists.debian.org/debian-lts-announce/2023/05/msg00010.html
- https://nvidia.custhelp.com/app/answers/detail/a_id/5415
- https://security.gentoo.org/glsa/202310-02
Get alerted when CVE-2022-34680 or the next vulnerability affects your stack