What’s Vulnerable › Vulnerabilities
CVE-2022-3469: WP Attachments < 5.0.5 - Admin+ Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Attachments WordPress plugin before 5.0.5 does not sanitize and escapes some of its settings, which could allow high-privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example, in multisite setup).
Affected products
- WP Attachments: before 5.0.5 — fixed in 5.0.5
How to fix
Upgrade to a fixed version: WP Attachments 5.0.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/017ca231-e019-4694-afa2-ab7f8481ae63
- https://wpscan.com/vulnerability/017ca231-e019-4694-afa2-ab7f8481ae63
Get alerted when CVE-2022-3469 or the next vulnerability affects your stack