What’s Vulnerable › Vulnerabilities
CVE-2022-34857: WordPress SP Project & Document Manager plugin <= 4.59 - Reflected Cross-Site Scripting (XSS) vulnerability
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-22 · updated 2026-06-17
- Weakness: CWE-79
Description
Reflected Cross-Site Scripting (XSS) vulnerability in smartypants SP Project & Document Manager plugin <= 4.59 at WordPress
Affected products
- Smartypants SP Project & Document Manager: before 4.62 — fixed in 4.62
How to fix
Upgrade to a fixed version: Smartypants SP Project & Document Manager 4.62. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/sp-client-document-manager/wordpress-sp-project-document-manager-plugin-4-59-reflected-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/sp-client-document-manager/#developers
- https://patchstack.com/database/vulnerability/sp-client-document-manager/wordpress-sp-project-document-manager-plugin-4-59-reflected-cross-site-scripting-xss-vulnerability
- https://wordpress.org/plugins/sp-client-document-manager/#developers
Get alerted when CVE-2022-34857 or the next vulnerability affects your stack