What’s Vulnerable › Vulnerabilities
CVE-2022-3490: Checkout Field Editor for WooCommerce < 1.8.0 - Admin+ PHP Object Injection
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-28 · updated 2026-06-17
Description
The Checkout Field Editor (Checkout Manager) for WooCommerce WordPress plugin before 1.8.0 unserializes user input provided via the settings, which could allow high privilege users such as admin to perform PHP Object Injection when a suitable gadget is present
Affected products
- themehigh Checkout Field Editor (Checkout Manager) for WooCommerce: before 1.8.0 — fixed in 1.8.0
How to fix
Upgrade to a fixed version: themehigh Checkout Field Editor (Checkout Manager) for WooCommerce 1.8.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0c9f22e0-1d46-4957-9ba5-5cca78861136
- https://wpscan.com/vulnerability/0c9f22e0-1d46-4957-9ba5-5cca78861136
Get alerted when CVE-2022-3490 or the next vulnerability affects your stack