What’s Vulnerable › Vulnerabilities
CVE-2022-3491: Heap-based Buffer Overflow in vim/vim
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-03 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0742.
Affected products
- vim/vim: before 9.0.0742 — fixed in 9.0.0742
How to fix
Upgrade to a fixed version: vim/vim 9.0.0742. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/3558afe9e9e904cabb8475392d859f2d2fc21041
- https://huntr.dev/bounties/6e6e05c2-2cf7-4aa5-a817-a62007bf92cb
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/3558afe9e9e904cabb8475392d859f2d2fc21041
- https://huntr.dev/bounties/6e6e05c2-2cf7-4aa5-a817-a62007bf92cb
- https://security.gentoo.org/glsa/202305-16
Get alerted when CVE-2022-3491 or the next vulnerability affects your stack