What’s Vulnerable › Vulnerabilities
CVE-2022-34916: Improper Input Validation (JNDI Injection) in JMSMessageConsumer
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-21 · updated 2026-06-17
- Weakness: CWE-20
Description
Apache Flume versions 1.4.0 through 1.10.0 are vulnerable to a remote code execution (RCE) attack when a configuration uses a JMS Source with a JNDI LDAP data source URI when an attacker has control of the target LDAP server. This issue is fixed by limiting JNDI to allow only the use of the java protocol or no protocol.
Affected products
- Apache Software Foundation Apache Flume: from 1.4.0 before 1.10.1 — fixed in 1.10.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Flume 1.10.1. Check the vendor advisory for mitigations.
References
- https://issues.apache.org/jira/browse/FLUME-3428
- https://lists.apache.org/thread/qkmt4r2t9tbrxrdbjg1m2oczbvczd9zn
- https://issues.apache.org/jira/browse/FLUME-3428
- https://lists.apache.org/thread/qkmt4r2t9tbrxrdbjg1m2oczbvczd9zn
Get alerted when CVE-2022-34916 or the next vulnerability affects your stack