What’s Vulnerable › Vulnerabilities

CVE-2022-34918

Description

An issue was discovered in the Linux kernel through 5.18.9. A type confusion bug in nft_set_elem_init (leading to a buffer overflow) could be used by a local attacker to escalate privileges, a different vulnerability than CVE-2022-32250. (The attacker can obtain root access, but must start with an unprivileged user namespace to obtain CAP_NET_ADMIN access.) This can be fixed in nft_setelem_parse_data in net/netfilter/nf_tables_api.c.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.316, 4.19.284, 5.10.130, 5.15.54. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-34918 or the next vulnerability affects your stack