What’s Vulnerable › Vulnerabilities
CVE-2022-3494: Complianz (Free < 6.3.4, Premium < 6.3.6) - Translator SQLi
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-89
Description
The Complianz WordPress plugin before 6.3.4, and Complianz Premium WordPress plugin before 6.3.6 allow a translators to inject arbitrary SQL through an unsanitized translation. SQL can be injected through an infected translation file, or by a user with a translator role through translation plugins such as Loco Translate or WPML.
Affected products
- Complianz – GDPR/CCPA Cookie Consent: before 6.3.4; before 6.3.6 — fixed in 6.3.4, 6.3.6
How to fix
Upgrade to a fixed version: Complianz – GDPR/CCPA Cookie Consent 6.3.4, 6.3.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/71db75c0-5907-4237-884f-8db88b1a9b34
- https://wpscan.com/vulnerability/71db75c0-5907-4237-884f-8db88b1a9b34
Get alerted when CVE-2022-3494 or the next vulnerability affects your stack