What’s Vulnerable › Vulnerabilities
CVE-2022-34970
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-193
Description
Crow before 1.0+4 has a heap-based buffer overflow via the function qs_parse in query_string.h. On successful exploitation this vulnerability allows attackers to remotely execute arbitrary code in the context of the vulnerable service.
Affected products
- Crow: before 1.0\+4 — fixed in 1.0\+4
How to fix
Upgrade to a fixed version: Crow 1.0\+4. Check the vendor advisory for mitigations.
References
- https://cwe.mitre.org/data/definitions/193.html
- https://github.com/0xhebi/CVE-2022-34970/blob/master/report.md
- https://github.com/CrowCpp/Crow/pull/486
- https://github.com/CrowCpp/Crow/releases/tag/v1.0%2B4
- https://cwe.mitre.org/data/definitions/193.html
- https://github.com/0xhebi/CVE-2022-34970/blob/master/report.md
- https://github.com/CrowCpp/Crow/pull/486
- https://github.com/CrowCpp/Crow/releases/tag/v1.0%2B4
Get alerted when CVE-2022-34970 or the next vulnerability affects your stack