What’s Vulnerable › Vulnerabilities
CVE-2022-3506: Cross-site Scripting (XSS) - Stored in barrykooij/related-posts-for-wp
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-14 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository barrykooij/related-posts-for-wp prior to 2.1.3.
Affected products
- Related Posts for WordPress: before 2.1.3 — fixed in 2.1.3
How to fix
Upgrade to a fixed version: Related Posts for WordPress 2.1.3. Check the vendor advisory for mitigations.
References
- https://github.com/barrykooij/related-posts-for-wp/commit/37733398dd88863fc0bdb3d6d378598429fd0b81
- https://huntr.dev/bounties/08251542-88f6-4264-9074-a89984034828
- https://github.com/barrykooij/related-posts-for-wp/commit/37733398dd88863fc0bdb3d6d378598429fd0b81
- https://huntr.dev/bounties/08251542-88f6-4264-9074-a89984034828
Get alerted when CVE-2022-3506 or the next vulnerability affects your stack