What’s Vulnerable › Vulnerabilities

CVE-2022-3513

Description

An issue has been discovered in GitLab affecting all versions starting from 12.8 before 15.8.5, all versions starting from 15.9 before 15.9.4, all versions starting from 15.10 before 15.10.1. A specially crafted payload could lead to a reflected XSS on the client side which allows attackers to perform arbitrary actions on behalf of victims on self-hosted instances running without strict CSP.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.8.5, 15.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3513 or the next vulnerability affects your stack