What’s Vulnerable › Vulnerabilities

CVE-2022-3514

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 6.6 before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. An attacker may cause Denial of Service on a GitLab instance by exploiting a regex issue in the submodule URL parser.

Affected products

How to fix

Upgrade to a fixed version: GitLab 15.5.7, 15.6.4, 15.7.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-3514 or the next vulnerability affects your stack