What’s Vulnerable › Vulnerabilities
CVE-2022-3515
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-12 · updated 2026-06-17
- Weakness: CWE-190
Description
A vulnerability was found in the Libksba library due to an integer overflow within the CRL parser. The vulnerability can be exploited remotely for code execution on the target system by passing specially crafted data to the application, for example, a malicious S/MIME attachment.
Affected products
- GnuPG: from 2.1.0 before 2.2.41; from 2.3.0 before 2.4.0 — fixed in 2.2.41, 2.4.0
- GnuPG Libksba: before 1.6.3 — fixed in 1.6.3
- GnuPG Vs-Desktop: from 3.1.16 before 3.1.26 — fixed in 3.1.26
- Gpg4Win: from 2.0.0 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: GnuPG 2.2.41, 2.4.0; GnuPG Libksba 1.6.3; GnuPG Vs-Desktop 3.1.26; Gpg4Win 4.1.0. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2022-3515
- https://bugzilla.redhat.com/show_bug.cgi?id=2135610
- https://dev.gnupg.org/rK4b7d9cd4a018898d7714ce06f3faf2626c14582b
- https://security.netapp.com/advisory/ntap-20230706-0008/
- https://www.gnupg.org/blog/20221017-pepe-left-the-ksba.html
- https://access.redhat.com/security/cve/CVE-2022-3515
- https://bugzilla.redhat.com/show_bug.cgi?id=2135610
- https://dev.gnupg.org/rK4b7d9cd4a018898d7714ce06f3faf2626c14582b
- https://security.netapp.com/advisory/ntap-20230706-0008/
- https://www.gnupg.org/blog/20221017-pepe-left-the-ksba.html
Get alerted when CVE-2022-3515 or the next vulnerability affects your stack