What’s Vulnerable › Vulnerabilities
CVE-2022-3516: Cross-site Scripting (XSS) - Stored in librenms/librenms
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/8e85698aa3aa4884c2f3d6c987542477eb64f07c
- https://huntr.dev/bounties/734bb5eb-715c-4b64-bd33-280300a63748
- https://github.com/librenms/librenms/commit/8e85698aa3aa4884c2f3d6c987542477eb64f07c
- https://huntr.dev/bounties/734bb5eb-715c-4b64-bd33-280300a63748
Get alerted when CVE-2022-3516 or the next vulnerability affects your stack