What’s Vulnerable › Vulnerabilities
CVE-2022-3520: Heap-based Buffer Overflow in vim/vim
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-02 · updated 2026-06-17
- Weakness: CWE-122
Description
Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0765.
Affected products
- vim/vim: before 9.0.0765 — fixed in 9.0.0765
How to fix
Upgrade to a fixed version: vim/vim 9.0.0765. Check the vendor advisory for mitigations.
References
- https://github.com/vim/vim/commit/36343ae0fb7247e060abfd35fb8e4337b33abb4b
- https://huntr.dev/bounties/c1db3b70-f4fe-481f-8a24-0b1449c94246
- https://security.gentoo.org/glsa/202305-16
- https://github.com/vim/vim/commit/36343ae0fb7247e060abfd35fb8e4337b33abb4b
- https://huntr.dev/bounties/c1db3b70-f4fe-481f-8a24-0b1449c94246
- https://security.gentoo.org/glsa/202305-16
- https://security.netapp.com/advisory/ntap-20241115-0010/
Get alerted when CVE-2022-3520 or the next vulnerability affects your stack