What’s Vulnerable › Vulnerabilities
CVE-2022-35235: WordPress WPide plugin <= 2.6 - Authenticated Arbitrary File Read vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-23 · updated 2026-06-17
- Weakness: CWE-22
Description
Authenticated (admin+) Arbitrary File Read vulnerability in XplodedThemes WPide plugin <= 2.6 at WordPress.
Affected products
- xplodedthemes Wpide - File Manager & Code Editor: before 3.0 — fixed in 3.0
How to fix
Upgrade to a fixed version: xplodedthemes Wpide - File Manager & Code Editor 3.0. Check the vendor advisory for mitigations.
References
- https://patchstack.com/database/vulnerability/wpide/wordpress-wpide-plugin-2-6-authenticated-arbitrary-file-read-vulnerability
- https://wordpress.org/plugins/wpide/#developers
- https://patchstack.com/database/vulnerability/wpide/wordpress-wpide-plugin-2-6-authenticated-arbitrary-file-read-vulnerability
- https://wordpress.org/plugins/wpide/#developers
Get alerted when CVE-2022-35235 or the next vulnerability affects your stack