What’s Vulnerable › Vulnerabilities
CVE-2022-35241: NGINX Instance Manager vulnerability CVE-2022-35241
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-08-04 · updated 2026-06-17
- Weakness: CWE-400
Description
In versions 2.x before 2.3.1 and all versions of 1.x, when NGINX Instance Manager is in use, undisclosed requests can cause an increase in disk resource utilization. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.
Affected products
- F5 NGINX Instance Manager: from 1.0.0 through 1.0.4; from 2.0.0 before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: F5 NGINX Instance Manager 2.3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2022-35241 or the next vulnerability affects your stack