What’s Vulnerable › Vulnerabilities
CVE-2022-3525: Deserialization of Untrusted Data in librenms/librenms
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-20 · updated 2026-06-17
- Weakness: CWE-502
Description
Deserialization of Untrusted Data in GitHub repository librenms/librenms prior to 22.10.0.
Affected products
- librenms: before 22.10.0 — fixed in 22.10.0
How to fix
Upgrade to a fixed version: librenms 22.10.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/ae3925b09ad3c5d0f7a9d5a26ae2f2f778834948
- https://huntr.dev/bounties/ed048e8d-87af-440a-a91f-be1e65a40330
- https://github.com/librenms/librenms/commit/ae3925b09ad3c5d0f7a9d5a26ae2f2f778834948
- https://huntr.dev/bounties/ed048e8d-87af-440a-a91f-be1e65a40330
Get alerted when CVE-2022-3525 or the next vulnerability affects your stack