What’s Vulnerable › Vulnerabilities
CVE-2022-35256
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-05 · updated 2026-06-17
- Weakness: CWE-444
Description
The llhttp parser in the http module in Node v18.7.0 does not correctly handle header fields that are not terminated with CLRF. This may result in HTTP Request Smuggling.
Affected products
- Debian Linux: 11.0
- Llhttp: before 6.0.10 — fixed in 6.0.10
- Node.js: from 14.0.0 through 14.14.0; from 14.15.0 before 14.20.1; from 16.0.0 through 16.12.0; from 16.13.0 before 16.17.1; from 18.0.0 before 18.9.1 — fixed in 14.20.1, 16.17.1, 18.9.1
- Siemens SINEC INS: before 1.0; 1.0, 1.0-sp1, 1.0-sp2 — fixed in 1.0
How to fix
Upgrade to a fixed version: Llhttp 6.0.10; Node.js 14.20.1, 16.17.1, 18.9.1; Siemens SINEC INS 1.0. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-332410.pdf
- https://hackerone.com/reports/1675191
- https://www.debian.org/security/2023/dsa-5326
- https://cert-portal.siemens.com/productcert/pdf/ssa-332410.pdf
- https://hackerone.com/reports/1675191
- https://www.debian.org/security/2023/dsa-5326
Get alerted when CVE-2022-35256 or the next vulnerability affects your stack