What’s Vulnerable › Vulnerabilities
CVE-2022-35282
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-28 · updated 2026-06-17
- Weakness: CWE-918
Description
IBM WebSphere Application Server 7.0, 8.0, 8.5, and 9.0 is vulnerable to server-side request forgery (SSRF). By sending a specially crafted request, an attacker with local network access could exploit this vulnerability to obtain sensitive data.
Affected products
- IBM WebSphere Application Server: from 7.0.0.0 before 7.0.0.45; from 8.0.0.0 before 8.0.0.15; from 8.5.0.0 before 8.5.5.22; from 9.0.0.0 before 9.0.5.13 — fixed in 7.0.0.45, 8.0.0.15, 8.5.5.22, 9.0.5.13
How to fix
Upgrade to a fixed version: IBM WebSphere Application Server 7.0.0.45, 8.0.0.15, 8.5.5.22, 9.0.5.13. Check the vendor advisory for mitigations.
References
- https://exchange.xforce.ibmcloud.com/vulnerabilities/230809
- https://www.ibm.com/support/pages/node/6824179
- https://exchange.xforce.ibmcloud.com/vulnerabilities/230809
- https://www.ibm.com/support/pages/node/6824179
Get alerted when CVE-2022-35282 or the next vulnerability affects your stack