What’s Vulnerable › Vulnerabilities
CVE-2022-3536: Role Based Pricing for WooCommerce < 1.6.3 - Subscriber+ PHAR Deserialization
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The Role Based Pricing for WooCommerce WordPress plugin before 1.6.3 does not have authorisation and proper CSRF checks, as well as does not validate path given via user input, allowing any authenticated users like subscriber to perform PHAR deserialization attacks when they can upload a file, and a suitable gadget chain is present on the blog
Affected products
- Role Based Pricing for WooCommerce: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: Role Based Pricing for WooCommerce 1.6.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/6af63aab-b7a6-4ef6-8604-4b4b99467a34
- https://wpscan.com/vulnerability/6af63aab-b7a6-4ef6-8604-4b4b99467a34
Get alerted when CVE-2022-3536 or the next vulnerability affects your stack