What’s Vulnerable › Vulnerabilities
CVE-2022-3537: Role Based Pricing for WooCommerce < 1.6.2 - Subscriber+ Arbitrary File Upload
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-07 · updated 2026-06-17
- Weakness: CWE-352
Description
The Role Based Pricing for WooCommerce WordPress plugin before 1.6.2 does not have authorisation and proper CSRF checks, and does not validate files to be uploaded, allowing any authenticated users like subscriber to upload arbitrary files, such as PHP
Affected products
- Role Based Pricing for WooCommerce: before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Role Based Pricing for WooCommerce 1.6.2. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/696868f7-409d-422d-87f4-92fc6bf6e74e
- https://wpscan.com/vulnerability/696868f7-409d-422d-87f4-92fc6bf6e74e
Get alerted when CVE-2022-3537 or the next vulnerability affects your stack